Sie sind vermutlich noch nicht im Forum angemeldet - Klicken Sie hier um sich kostenlos anzumelden Impressum 
  Forum Übersicht   Suche    Anmelden    Login   Online ?   Mitglieder   FAQ
Sie können sich hier anmelden
Dieses Thema hat 10 Antworten
und wurde 1.213 mal aufgerufen
Bei Antworten informieren
 Installation des Webservers
Alexander Ramisch Offline



Beiträge: 372

17.11.2006 22:02
res not found antworten

Hallo,

wenn der Webserver beim Anmelden diese Meldung bringt: "*** res not found ***" ist es ein Zeichen dafür, dass nicht die richtige .NET Version installiert ist. Der Webserver benötigt nämlich .NET 1.1 in genau der Version, die auf der Installations-CD verteilt wird.
Es gibt einen HotFix zu .NET 1.1, der dazu führt, dass der Webserver nicht mehr korrekt läuft.
In diesem Fall hilft folgendes: .NET 1.1 deinstallieren und die folgende Version installieren:
http://www.pixafe.com/downloads/dotnetfx.exe

Schöne Grüße
Alex
---
Alexander Ramisch mailto:info@pixafe.com
pixafe GbR http://www.pixafe.com
pixafe - die Bilderdatenbank
Erhard Auer Straße 8 , D-80637 Muenchen
Tel +49 89 87589575 Fax +49 89 15919775

A.Lang Offline



Beiträge: 1

09.05.2007 14:22
#2 RE: res not found antworten

Gibt es noch eine Möglichkeit, warum diese Fehlermeldung auftritt?

Ich habe wie oben beschrieben und genau diese Version von .NET 1.1 installiert.
Der MandantMode wurde ebenfalls auf NEIN gestellt und das Gerät wo der Pixafe Webserver läuft wurde auch bereits neu gestartet.

Bin für jeden Hinweis dankbar!

Mit freundlichen Grüßen,
A.Lang

Alexander Ramisch Offline



Beiträge: 372

09.05.2007 17:08
#3 RE: res not found antworten

Hallo,

es muss auch der Webserver zu der zugrundeliegenden pixafe-Version passen. Beispielsweise funtkioniert der alte Webserver nicht mehr, der für pixafe Version 4 realisiert wurde zusammen mit pixafe 5.

Grüße
Alex

---
Alexander Ramisch mailto:info@pixafe.com
pixafe GbR http://www.pixafe.com
pixafe - die Bilderdatenbank
Erhard Auer Straße 8 , D-80637 Muenchen
Tel +49 89 87589575 Fax +49 89 15919775

Gerald Offline




Beiträge: 101

04.10.2008 15:07
#4 RE: res not found antworten

Hallo,

ich habe nun das gleiche Problem.

Mein Webserver hat sich über Autoupdate den IExplorer 7 und dazu gleich .Net 2.0 gezogen und installiert.

Das habe ich jetzt wieder deinstalliert, nutzt aber nix. ich kann 1.1 nicht mehr manuell nachinstallieren. Meldung in der Anlage...

@Alex: bitte habe eine Lösung, ich will den Server nicht neu machen!

---
Viele Grüße,
Gerald

Angefügte Bilder:
Screen 92.jpg  
Peter Offline



Beiträge: 847

07.10.2008 15:09
#5 RE: res not found antworten

Hi Gerald,

sorry, dass ich mich jetzt erst melde, aber ich hatte Einsatz beim Kunden...
Bitte nenne mir das genaue Problem / Fehlermeldung die du bekommst beim Betrieb des Webservers.
Mit .NET ist es ja so, dass neue Versionen die alten nicht überschreiben, sondern, dass diese "nebeneinander" betrieben werden.
Wahrscheinlich brauchst du nur das ASP.NET 1.1 zu reaktivieren, ich denke dazu gibt es einen Befehl in der .NET Kommandozeile. Das suche ich dann raus, wenn ich genau weiss, wo das Problem liegt.

Gruß
Peter

Gerald Offline




Beiträge: 101

11.10.2008 09:15
#6 RE: res not found antworten

Hallo Peter,

ich bekommen die Anmeldeseite und nach Eingabe von Benutzername und Passwort "***res not found***"

---
Viele Grüße,
Gerald

Peter Offline



Beiträge: 847

14.10.2008 13:47
#7 RE: res not found antworten

Hallo Gerald,

ich denke du könntest Glück haben, wenn du das Tool aspnet_regiis.exe nutzt. Es kann sein, dass ASP.NET einfach neu konfiguriert werden muss. Hier findest du eine Beschreibung dazu: http://msdn.microsoft.com/en-us/library/k6h9cz8h(VS.80).aspx

Hier ein Auszug aus der Beschreibung:
When multiple versions of the .NET Framework are executing side-by-side on a single computer, the ASP.NET ISAPI version mapped to an ASP.NET application determines which version of the common language runtime (CLR) is used for the application. The ASP.NET IIS Registration Tool (Aspnet_regiis.exe) allows an administrator or installation program to easily update the script maps for an ASP.NET application to point to the ASP.NET ISAPI version that is associated with the tool. The tool can also be used to display the status of all installed versions of ASP. NET, register the ASP.NET version that is coupled with the tool, create client-script directories, and perform other configuration operations.

Das Programm aspnet_regiis.exe liegt im .NET Verzeichnis ( c:\windows\Microsoft.NET\Framework\v1... hier die jeweilige Version des .NET Frameworks)

Starte einfach eine Shell (cmd.exe) und gib ein aspnet_regiis.exe, dann bekommst du die möglichen Optionen.

Grüße
Peter

Gerald Offline




Beiträge: 101

15.10.2008 08:26
#8 RE: res not found antworten

Hallo Peter,

ich habe das jetzt versucht aber leider ohne Erfolg. Mit der Option -i -enable.
Für -s weiss ich leider nicht die restlichen Parameter.

Allerdings vielleicht noch das anhängende Bild. ASP.Net 1.1.4322 ist ja registriert.

Kann es daran liegen, dass ich pixafe als V6.011 verwende aber noch einen V5 Webserver installiert habe? Gibt es schon einen V6 WEB Server? Wo bekomme ich diesen her?

---
Viele Grüße,
Gerald

Angefügte Bilder:
Screen 100.jpg  
Alexander Ramisch Offline



Beiträge: 372

17.10.2008 08:11
#9 RE: res not found antworten

Hallo Gerald,

mit dem Update auf Version 6 werden bei installiertem Webserver auch die entsprechenden Zugriffskomponenten des Webservers automatisch aktualisiert. Darum kann das nicht das Problem sein.
Der Webserver schreibt auch in die Logdatei. Kannst du uns bitte sagen, welcher Fehler gemeldet wird?
Ich hätte eher an die Option -r gedacht. Die Parameter sind doch alle beschrieben unter dem angegebenen Link:
http://msdn.microsoft.com/en-us/library/k6h9cz8h.aspx

Schöne Grüße
Alex

---
Alexander Ramisch mailto:info@pixafe.com
pixafe GbR http://www.pixafe.com
pixafe - die Bilderdatenbank
Elisabeth Jost Straße 6 , D-81245 Muenchen
Tel +49 89 87589575 Fax +49 89 15919775

Gerald Offline




Beiträge: 101

24.10.2008 12:08
#10 RE: res not found antworten

Hallo,

also "aspnet_regiis.exe -r" war die Lösung des Problems. Dann werden in allen Scripts die ASP.NET Verweise wieder auf die richtige Version eingestellt.

Wichtig ist natürlich, dass dieses Kommando aus dem richtigen Verzeichnis heraus aufgerufen wird.

C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322


Was ich allerdings nicht beobachten konnte, dass der Webserver in die Tracedatei schreibt!

---
Viele Grüße,
Gerald

Peter Offline



Beiträge: 847

28.11.2008 10:57
#11 RE: res not found antworten

Hallo,

noch ein Nachtrag: es ist ganz wichtig, dass zuerst ASP auf die Version 1.1 gebracht wird, also mittels
aspnet_regiis.exe -i im Verzeichnis C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322
und dann auch noch aspnet_regiis.exe -r im selben Verzeichnis aufrufen.
Und erst DANACH den Webserver mit der ausgelieferten Setup-Datei installieren.

Gruß,
Peter

 Sprung