Sie sind vermutlich noch nicht im Forum angemeldet - Klicken Sie hier um sich kostenlos anzumelden Impressum 
  Forum Übersicht   Suche    Anmelden    Login   Online ?   Mitglieder   FAQ
Sie können sich hier anmelden
Dieses Thema hat 2 Antworten
und wurde 151 mal aufgerufen
Bei Antworten informieren
 Korrekturen und Erweiterungen
JBM Offline



Beiträge: 142

25.07.2010 00:22
V7.018 - "Alte" SideCars antworten

Hallo Peter und Alex,
nachdem ich nun die V7.018 auf meinen Hauptrechner gespielt habe und somit auf meinen Bildbestand loslasse, habe ich gleich mal eine Rückmeldung zum Thema "SideCars":
Also - mal schön der Reihe nach ...

Vor dem Umstieg auf die V7 habe ich die V6 nochnmal durchgecheckt (Datenbank - Administration - Bildverzeichnis prüfen - usw.). Da war alles o.k. und konsistent.
Einzige, bewusst in Kauf genommene Ausnahme war ein fehlendes Thumbnail zu einer RAW-Datei. (Der Grund für diese Ausnahme war der Fehler in der V6, der beim Neuerstellen eines TN zu einem RAW-Bild dieses quasi aus der DB geworfen hat - siehe separates Posting; dieses Thumbnail wurde mittlerweile in der V7.018 anstandslos generiert - alles o.k.)

In der V7.018 habe ich nun ebenso die DB durchgecheckt (Datenbank - Administration - Bildverzeichnis prüfen - usw.). Ergenbnis:
- Anzahl der Bilder und RAW-Dateien in DB ist i.O.
- Alle Bilder der DB sind auch im Dateiverzeichnis
- 289 Bilder des Dateisystems sind aber angeblich nicht in der DB.
Hierbei handelt es sich ausnahmslos um XMP-Files. Es sind genau diejenigen Files, die bei der erstmaligen Einführung der Sidecar-Verwaltung in "V6.irgendwas" manuell ins RAW-Verzeichnis kopiert worden waren. (Ihr erinnert Euch vielleicht: Ich hatte damals noch gefragt, ob die XMPs nicht umbenannt werden müssten, was dann aber verneint wurde.)
Die von Pixafe automatisch importierten XMPs sind alle entsprechend der Bildnummer umbenannt und werden in V7 folglich richtig zugeordnet.

Der Rest ist dann wie erwartet gelaufen:
Beim Export ("Speichern unter...") eines "alten" Bildes (ID 3480, Dateiname DSC_1716.NEF, SideCar DSC_1716.XMP) wird das XMP-File nicht mit ausgespuckt, obwohl es natürlich im Bilderordner vorhanden ist.
Beim Export eines neueren (automatisch mit SideCar importierten Bildes) klappt alles prima und das Side wird mit ausgegeben.

Wie lösen wir das Problemchen?
Ich könnte es verstehen, wenn Ihr die "unsaubere" Verknüpfung über den ursprünglichen Dateinamen nicht mehr beibehalten wollt. In diesem Fall bräuchte ich aber irgendeine praktikable Möglichkeit, das automatisch gradezuziehen. Ich habe schon an einen Export ("Exportieren") der betroffenen Bilder gedacht. Danach wären die RAWs ja wieder mit dem ursprünglichen, zum XMP passenden Dateinamen vorhanden. Dabei bleiben aber 2 Schwierigkeiten:
1. Wie selektiere ich die betroffenen Bilder in der DB (ohne manuell durch die zu lange Liste gehen zu müssen)?
2. Wie krieg ich das Ganze (mit der XMP-Datei und der vorhandenen Beschriftungs- und Bildgruppeninformation) dann wieder in die DB eingelesen? Die Metainformation in der PAI-Datei verweist ja nicht auf das XMP-File ...
... villeicht dann doch lieber die Fortführung der "unsauberen" Verknüpfung zwischen RAW und Sidecar über die Dateinamen und/oder die Bildnummer?

Danke, Gruß und bis zum nächsten Posting :)

Jürgen

Peter Offline



Beiträge: 847

18.12.2010 09:05
#2 RE: V7.018 - "Alte" SideCars antworten

Siehe auch Version V7034
Gruß
Peter

JBM Offline



Beiträge: 142

20.12.2010 00:01
#3 RE: V7.018 - "Alte" SideCars antworten

Hallo Peter,

so sehr ich die neuen Möglichkeiten der V7.035 und 035 auch mag, aber das in diesem Beitrag von mir beschriebene Problem wird hiermit nicht beseitigt - es sei denn, ich hab da was übersehen.
Wie im beigefügten Screenshot zu sehen, werden die "alten" Sidecars noch immer als überflüssig behandelt ...

Gruß
Jürgen

Angefügte Bilder:
Bildverzeichnis_prüfen.jpg  
 Sprung