Sie sind vermutlich noch nicht im Forum angemeldet - Klicken Sie hier um sich kostenlos anzumelden Impressum 
  Forum Übersicht   Suche    Anmelden    Login   Online ?   Mitglieder   FAQ
Sie können sich hier anmelden
Dieses Thema hat 16 Antworten
und wurde 6.468 mal aufgerufen
Bei Antworten informieren
 Häufig gestellte Fragen
Seiten 1 | 2
Universität Wien Offline



Beiträge: 1

24.12.2007 17:35
Webserver: "Serverfehler in der Anwendung ´/´. Laufzeitfehler antworten

Guten Tag. Die Installtation ist nach einigen Macken ( Apache hat port 80 belegt) eigentlich ohne Fehlermeldung von Statten gegangen - leider bekomme ich nach Aufruf der website (x.x.x/pixafe) immer die obengenannte Fehlermeldung. Re-installation hat nicht geholfen. Im web config file kann ich keine Fehler entdecken:-( Hat jemand eine sinnvolle Idee??? Vielen Dank im voraus und frohes Fest Markus

Alexander Ramisch Offline



Beiträge: 372

25.12.2007 09:06
#2 RE: Webserver: "Serverfehler in der Anwendung ´/´. Laufzeitfehler antworten

Hallo Markus,

ist .NET 1.1 installiert und ist auch ASP.NET aktiviert?
Der Webserver läuft nur auf dem Microsoft IIS

Grüße
Alex

---
Alexander Ramisch mailto:info@pixafe.com
pixafe GbR http://www.pixafe.com
pixafe - die Bilderdatenbank
Erhard Auer Straße 8 , D-80637 Muenchen
Tel +49 89 87589575 Fax +49 89 15919775

Universität Wien ( Gast )
Beiträge:

02.01.2008 17:28
#3 RE: Webserver: "Serverfehler in der Anwendung ´/´. Laufzeitfehler antworten

Danke für die Antwort.
Net 1.1 ist installiert (nach IIS)
Wie kann ich ASP.NET aktivieren (Win XP Prof SP2) - finde im Web keine passende Anleitung dafür (nur für 2003 server). Unter Internet Informationsdienste/Server/Websites/pixafe ist unter anderem ein aspnet_client folder - bedeutet dass es ist aktiviert? Beim googlen bin ich auf ein Programm namens aspnet_regiis.exe gestossen mit dem man Fehler nach Re-Installation (hab den Server schon ein mal installiert gehabt und dann wieder deinstalliert) beseitigen können soll - kann es damit zu tun haben - hab leider trotz ausgiebieger Such das Programm nicht zum Downloaden gefunden....
Sorry für meine Inkompetenz:-(
Markus

Alexander Ramisch Offline



Beiträge: 372

02.01.2008 20:00
#4 RE: Webserver: "Serverfehler in der Anwendung ´/´. Laufzeitfehler antworten

Kein Problem...
ASP.NET ist auf der Maschine mittels Software / Windows Komponenten zu aktivieren.

Grüße
Alex

---
Alexander Ramisch mailto:info@pixafe.com
pixafe GbR http://www.pixafe.com
pixafe - die Bilderdatenbank
Erhard Auer Straße 8 , D-80637 Muenchen
Tel +49 89 87589575 Fax +49 89 15919775

Gast
Beiträge:

22.01.2008 16:01
#5 RE: Webserver: "Serverfehler in der Anwendung ´/´. Laufzeitfehler antworten

Ist leider nicht ganz so einfach:
in den Windows Komponenten gibts zwar IIS, dort aber kein ASP.net. Auch sonst in den Windows Komponenten nicht zu finden.
Auch die Anleitung auf div. Microsoft Seiten:

So aktivieren Sie ASP.NET mit dem IIS-Manager
1.Erweitern Sie im IIS-Manager den lokalen Computer, und klicken Sie dann auf Webdiensterweiterungen.
2.Klicken Sie im Detailfenster auf ASP.NET, und klicken Sie anschließend auf Zulassen.

funktioniert nicht da es bei mir keinen Ordner Webdiensterweiterungen gibt.(nur Websites und virtueller STandardserver).

GRRRR

Irgentwelche Ideen?

Markus

Alexander Ramisch Offline



Beiträge: 372

22.01.2008 16:16
#6 RE: Webserver: "Serverfehler in der Anwendung ´/´. Laufzeitfehler antworten

Soweit ich mich erinnern kann ist das als Zusatzkomponente unter Einstellungen/Software/Windowskomponenten einzustellen

Grüße
Alex

---
Alexander Ramisch mailto:info@pixafe.com
pixafe GbR http://www.pixafe.com
pixafe - die Bilderdatenbank
Erhard Auer Straße 8 , D-80637 Muenchen
Tel +49 89 87589575 Fax +49 89 15919775

Gast
Beiträge:

22.01.2008 17:28
#7 RE: Webserver: "Serverfehler in der Anwendung ´/´. Laufzeitfehler antworten

Nein, dort ist es leider nicht.
Habe nun Net 1.1 und das Bugfix nochmal installiert aber es funktioniert leider noch immer nicht. Scheinbar wird ASP.NET automatisch mit Net installiert und auch aktiviert - glaube also eher nicht dass es daran liegt.

Beim Aufruf der Website "ladet" der Browser kurz und bricht dann mit der obengenannten Fehlermeldung ab.

Wie könnte ich das Problem weiter eingrenzen?

Markus

Alexander Ramisch Offline



Beiträge: 372

22.01.2008 22:35
#8 RE: Webserver: "Serverfehler in der Anwendung ´/´. Laufzeitfehler antworten

---
Alexander Ramisch mailto:info@pixafe.com
pixafe GbR http://www.pixafe.com
pixafe - die Bilderdatenbank
Erhard Auer Straße 8 , D-80637 Muenchen
Tel +49 89 87589575 Fax +49 89 15919775

Gast
Beiträge:

23.01.2008 16:31
#9 RE: Webserver: "Serverfehler in der Anwendung ´/´. Laufzeitfehler antworten

Leider nicht da ich wie oben beschrieben Windows XP Prof laufen habe - all diese Anleitungen beziehen sich auf die Server Varianten.
Die im Artikel beschriebenen Einträge sind bei mir daher alle nicht vorhanden:-(

Alexander Ramisch Offline



Beiträge: 372

23.01.2008 19:26
#10 RE: Webserver: "Serverfehler in der Anwendung ´/´. Laufzeitfehler antworten

Das geht auch unter Windows XP. Bevor du den IIS installierst, solltest du alle aktuellen Service Packs installiert haben, siehe
http://www.w3schools.com/aspnet/aspnet_install.asp

Grüße
Alex

---
Alexander Ramisch mailto:info@pixafe.com
pixafe GbR http://www.pixafe.com
pixafe - die Bilderdatenbank
Erhard Auer Straße 8 , D-80637 Muenchen
Tel +49 89 87589575 Fax +49 89 15919775

Gast
Beiträge:

30.01.2008 17:13
#11 RE: Webserver: "Serverfehler in der Anwendung ´/´. Laufzeitfehler antworten

In dieser Anleitung steht wie man .NET installiert - das habe ich sowieso schon gemacht.
Gibt es ausser fehlendem ASP noch andere Gründe für diesen Fehler?
Grüße

Markus

Peter Offline



Beiträge: 847

30.01.2008 20:36
#12 RE: Webserver: "Serverfehler in der Anwendung ´/´. Laufzeitfehler antworten

Hi Markus,

das einzige Problem ist, dass du ASP.NET noch nicht aktiviert hast.

Eine Anfrage bei Google zu "ASP.NET Aktivieren auf Windows XP" bringt u.a. folgenden Link
http://support.microsoft.com/kb/928710/de

Dort ist beschrieben, wie du ASP.NET auf Microsoft Windows Server 2003, Microsoft Windows XP Professional und Microsoft Windows 2000 installierst.

Gruß
Peter

Gast
Beiträge:

31.01.2008 16:01
#13 RE: Webserver: "Serverfehler in der Anwendung ´/´. Laufzeitfehler antworten

hallo peter
In der Anleitung steht wie man IIS und das Framework installiert - das hab ich aber beides schon lange gemacht.
Mit den Frontpage-Servererweiterungen hat das nichts zu tun oder?
Hat es Sinn .Net 2.0 zu installieren - eigentlich sollte ja 1.1 reichen, oder?

Danke

Markus

Peter Offline



Beiträge: 847

01.02.2008 00:34
#14 RE: Webserver: "Serverfehler in der Anwendung ´/´. Laufzeitfehler antworten

Schritt 5:
5. Aktivieren Sie das ASP.NET aktivieren Kontrolle-Kästchen, und klicken Sie dann auf Weiter.

MIt Frontpage hat das nix zu tun

Grüße
Peter

Gast
Beiträge:

01.02.2008 15:11
#15 RE: Webserver: "Serverfehler in der Anwendung ´/´. Laufzeitfehler antworten

Die Zeile auf die du dich beziehst beschreibt den Vorgang für Windows 2003 Server! Bei XP (siehe darunter) gibt es dieses Kästchen nicht.:-(
Markus

Seiten 1 | 2
 Sprung